aboutsummaryrefslogtreecommitdiffstats
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorNeels Hofmeyr <neels@hofmeyr.de>2020-09-18 18:00:50 +0200
committerNeels Hofmeyr <neels@hofmeyr.de>2020-10-07 15:37:50 +0200
commit02de87bd5c8ed02e26ade44d07e78b541d3b62d1 (patch)
tree6da683d5124e64faacc73d068a8221e701158b3e /tests/Makefile.am
parentc6848f41455068a3bb59ca937293d2c0da0af14d (diff)
add BSSMAP-LE coding for Location Services
BSSMAP-LE: add Lb-interface messages between BSC and SMLC: - Reset - Reset Acknowledge - Perform Location Request, possibly containing BSSLAP TA Layer3 - Perform Location Response - Perform Location Abort - Connection Oriented Information containing any BSSLAP APDU Add encoding and decoding tests. Change-Id: I271e59b794bafc0a7ae0eabbf58918f6d7df431d
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index fc994852..152eb60b 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -40,6 +40,7 @@ check_PROGRAMS = timer/timer_test sms/sms_test ussd/ussd_test \
bitgen/bitgen_test \
gad/gad_test \
bsslap/bsslap_test \
+ bssmap_le/bssmap_le_test \
$(NULL)
if ENABLE_MSGFILE
@@ -289,6 +290,9 @@ gad_gad_test_LDADD = $(LDADD) $(top_builddir)/src/gsm/gad.o
bsslap_bsslap_test_SOURCES = bsslap/bsslap_test.c
bsslap_bsslap_test_LDADD = $(LDADD) $(top_builddir)/src/gsm/libosmogsm.la
+bssmap_le_bssmap_le_test_SOURCES = bssmap_le/bssmap_le_test.c
+bssmap_le_bssmap_le_test_LDADD = $(LDADD) $(top_builddir)/src/gsm/libosmogsm.la
+
# The `:;' works around a Bash 3.2 bug when the output is not writeable.
$(srcdir)/package.m4: $(top_srcdir)/configure.ac
:;{ \
@@ -371,6 +375,7 @@ EXTRA_DIST = testsuite.at $(srcdir)/package.m4 $(TESTSUITE) \
bitgen/bitgen_test.ok \
gad/gad_test.ok \
bsslap/bsslap_test.ok \
+ bssmap_le/bssmap_le_test.ok \
$(NULL)
if ENABLE_LIBSCTP