aboutsummaryrefslogtreecommitdiffstats
path: root/src/vty/Makefile.am
diff options
context:
space:
mode:
authorPau Espin Pedrol <pespin@sysmocom.de>2020-07-28 11:57:51 +0200
committerlaforge <laforge@osmocom.org>2020-08-10 14:11:18 +0000
commiteb6882fa5249c1f4fd764f4339ff7d749e1cfb99 (patch)
treeebde0bec33713ff53472316c2f88dac308bf9b7a /src/vty/Makefile.am
parent7dbae9ea40e2855729f9efa7264b5af78af779db (diff)
vty: Introduce support to set cpu-affinity and scheduler policy
Process willing to support this kind of configuration through VTY simply need to call "osmo_sched_vty_init(tall_ctx);" during startup to register the commands. For multithreaded processes, new threads willing to get their cpu-affinity mask according to VTY config should call osmo_sched_vty_apply_localthread() (potentially after setting the thread name through pthread_setname_np()). Related: SYS#4986 Change-Id: If76a4bd2cc7b3c7adf5d84790a944d78be70e10a
Diffstat (limited to 'src/vty/Makefile.am')
-rw-r--r--src/vty/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/vty/Makefile.am b/src/vty/Makefile.am
index 35350cc3..81ff1045 100644
--- a/src/vty/Makefile.am
+++ b/src/vty/Makefile.am
@@ -12,7 +12,7 @@ lib_LTLIBRARIES = libosmovty.la
libosmovty_la_SOURCES = buffer.c command.c vty.c vector.c utils.c \
telnet_interface.c logging_vty.c stats_vty.c \
fsm_vty.c talloc_ctx_vty.c \
- tdef_vty.c
+ cpu_sched_vty.c tdef_vty.c
libosmovty_la_LDFLAGS = -version-info $(LIBVERSION) -no-undefined
libosmovty_la_LIBADD = $(top_builddir)/src/libosmocore.la $(TALLOC_LIBS)
endif