aboutsummaryrefslogtreecommitdiffstats
path: root/src/gsm/Makefile.am
diff options
context:
space:
mode:
authorMax <msuraev@sysmocom.de>2017-10-30 13:19:58 +0100
committerMax <msuraev@sysmocom.de>2017-10-30 13:50:31 +0100
commitba1059c173ac8f4845464c4f91d1890898f729a0 (patch)
treea2b56f276eedd8675f1b51f629fb551dd3bbccac /src/gsm/Makefile.am
parentd9abb0a70869bdf4546d9cd0de39461773a1638f (diff)
Move additional libraries to appropriate place
According to https://www.gnu.org/software/automake/manual/automake.html#Libtool-Flags the libraries supposed to be added to *_LDADD or *_LIBADD while *_LDFLAGS should contain additional libtool linking flags. Previously we used both. Let's unify this and move all the libraries into proper automake variable. While at it - also add libosmocore.la for tests to LDADD since all the tests link against it anyway. Change-Id: Ia657a66db75df831421af5df1175a992da5ba80f
Diffstat (limited to 'src/gsm/Makefile.am')
-rw-r--r--src/gsm/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/src/gsm/Makefile.am b/src/gsm/Makefile.am
index 9b52f035..44769713 100644
--- a/src/gsm/Makefile.am
+++ b/src/gsm/Makefile.am
@@ -35,8 +35,8 @@ libgsmint_la_LDFLAGS = -no-undefined
libgsmint_la_LIBADD = $(top_builddir)/src/libosmocore.la
libosmogsm_la_SOURCES =
-libosmogsm_la_LDFLAGS = $(LTLDFLAGS_OSMOGSM) -version-info $(LIBVERSION) -no-undefined $(TALLOC_LIBS)
-libosmogsm_la_LIBADD = libgsmint.la
+libosmogsm_la_LDFLAGS = $(LTLDFLAGS_OSMOGSM) -version-info $(LIBVERSION) -no-undefined
+libosmogsm_la_LIBADD = libgsmint.la $(TALLOC_LIBS)
EXTRA_DIST = libosmogsm.map