aboutsummaryrefslogtreecommitdiffstats
path: root/src/gsm/Makefile.am
diff options
context:
space:
mode:
authorVadim Yanitskiy <axilirator@gmail.com>2018-07-02 20:28:55 +0700
committerVadim Yanitskiy <axilirator@gmail.com>2018-07-02 20:30:31 +0700
commit94c0031297abb0bb42a4ea23e68f944622f50469 (patch)
tree5e2382f50bdb9b26ddc27e058c2c3dcd87cc2ab6 /src/gsm/Makefile.am
parentbc568d0b9f216f8d3c26b888131f4a9a7e9d368d (diff)
Don't enforce Python 2 for utilities
The conv_gen.py utility was tested against both Python 2 and 3, so there is no need to enforce Python 2. Also, having: #!/usr/local/bin/python{2|3} is a bad idea, because Python may be installed in a different location. Change-Id: I6007d481047b584db13d6eda70fb99f11f9ddaa1
Diffstat (limited to 'src/gsm/Makefile.am')
-rw-r--r--src/gsm/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/gsm/Makefile.am b/src/gsm/Makefile.am
index 0439ce62..5387e3ab 100644
--- a/src/gsm/Makefile.am
+++ b/src/gsm/Makefile.am
@@ -47,6 +47,6 @@ EXTRA_DIST = libosmogsm.map
# Convolutional codes generation
gsm0503_conv.c: $(top_srcdir)/utils/conv_gen.py $(top_srcdir)/utils/conv_codes_gsm.py
- $(AM_V_GEN)python2 $(top_srcdir)/utils/conv_gen.py gen_codes gsm
+ $(AM_V_GEN)python $(top_srcdir)/utils/conv_gen.py gen_codes gsm
CLEANFILES = gsm0503_conv.c