aboutsummaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorHarald Welte <laforge@gnumonks.org>2015-12-05 23:38:18 +0100
committerHarald Welte <laforge@gnumonks.org>2015-12-05 23:38:18 +0100
commit90e614f7ccb0902e6ddb510bb10f78eb14a13d94 (patch)
treeb9e4d2365e3d387f1aebcee6bf0e32b4f4f1ff12 /src/Makefile.am
parentee702cd590688c1e65296319c5bc4c9cf160ba65 (diff)
remove our internal copy of talloc, use system libtalloc
Shipping our own private copy of talloc was a good idea in 2008, when it was not readily available on most target platforms. Today, the situation is quite different, as it is a standard library on major Linux distributions.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am16
1 files changed, 5 insertions, 11 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 00b97d08..32cefc8b 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -1,13 +1,13 @@
# This is _NOT_ the library release version, it's an API version.
# Please read Chapter 6 "Library interface versions" of the libtool documentation before making any modification
-LIBVERSION=6:0:0
+LIBVERSION=7:0:0
AM_CPPFLAGS = -I$(top_srcdir)/include -I$(top_builddir)/include
-AM_CFLAGS = -Wall
+AM_CFLAGS = -Wall $(TALLOC_CFLAGS)
lib_LTLIBRARIES = libosmocore.la
-libosmocore_la_LIBADD = $(BACKTRACE_LIB)
+libosmocore_la_LIBADD = $(BACKTRACE_LIB) $(TALLOC_LIBS)
libosmocore_la_SOURCES = timer.c select.c signal.c msgb.c bits.c \
bitvec.c statistics.c \
write_queue.c utils.c socket.c \
@@ -21,15 +21,9 @@ BUILT_SOURCES = crc8gen.c crc16gen.c crc32gen.c crc64gen.c
if ENABLE_PLUGIN
libosmocore_la_SOURCES += plugin.c
-libosmocore_la_LDFLAGS = -version-info $(LIBVERSION) $(LIBRARY_DL) -no-undefined
+libosmocore_la_LDFLAGS = -version-info $(LIBVERSION) $(TALLOC_LIBS) $(LIBRARY_DL) -no-undefined
else
-libosmocore_la_LDFLAGS = -version-info $(LIBVERSION) -no-undefined
-endif
-
-if ENABLE_TALLOC
-libosmocore_la_SOURCES += talloc.c
-else
-libosmocore_la_LIBADD += -ltalloc
+libosmocore_la_LDFLAGS = -version-info $(LIBVERSION) $(TALLOC_LIBS) -no-undefined
endif
if ENABLE_MSGFILE