aboutsummaryrefslogtreecommitdiffstats
path: root/include/osmocom/gsm/Makefile.am
diff options
context:
space:
mode:
authorroot <root@nuedel.(none)>2011-09-26 11:23:06 +0200
committerHarald Welte <laforge@gnumonks.org>2011-10-10 08:38:58 +0200
commitaf48bed556079313074d8a2ea132fd689af8a100 (patch)
treec027cc6e8f93257ddcda20c4f794d83760e443d0 /include/osmocom/gsm/Makefile.am
parent8a996b4844f8f89c16ce5062c74942d57f6f73b4 (diff)
Split of LAPDm into a core part and a GSM specific part
Instead of mixing together the GSM layer 1 interface and RSL interface with the implementation of LAPD, the core function of LAPD is now extracted from LAPDm. The core implementation is now in lapd_core.c and lapd_core.h respectively. The lapd_core.c implements exactly one datalink instance for one SAP. The surrounding implementation "lapdm.c" codes/decodes the layer 2 headers and handles multiplexing and datalink instances, as well as translates primitives from/to RSL layer. lapd_core.c can now be used for other LAPD implementations. (ISDN/ABIS)
Diffstat (limited to 'include/osmocom/gsm/Makefile.am')
-rw-r--r--include/osmocom/gsm/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/osmocom/gsm/Makefile.am b/include/osmocom/gsm/Makefile.am
index 90f19bc5..5971d0c5 100644
--- a/include/osmocom/gsm/Makefile.am
+++ b/include/osmocom/gsm/Makefile.am
@@ -1,6 +1,6 @@
osmogsm_HEADERS = a5.h comp128.h gsm0808.h gsm48_ie.h mncc.h rxlev_stat.h \
gsm0480.h gsm48.h gsm_utils.h rsl.h tlv.h abis_nm.h \
- sysinfo.h prim.h gsm0502.h lapdm.h
+ sysinfo.h prim.h gsm0502.h lapd_core.h lapdm.h
SUBDIRS = protocol