aboutsummaryrefslogtreecommitdiffstats
path: root/include/Makefile.am
diff options
context:
space:
mode:
authorNeels Hofmeyr <neels@hofmeyr.de>2020-09-18 18:00:50 +0200
committerNeels Hofmeyr <neels@hofmeyr.de>2020-10-07 11:39:46 +0000
commit086bd33f18fa79eb239a06e404915f3ba3c20e3f (patch)
tree9c808d123c773b3d13d7fe9fc82121ddefafce29 /include/Makefile.am
parent87c3afb5a969838446433c6d0d0ece8e9821e2c0 (diff)
add GAD coding for Location Services
GAD, Universal Geographical Area Description: - raw coding for all GAD elements. - SI-units encoding and decoding for Ellipsoid point with uncertainty circle, which I presume is the typical "at most N meters away from cell tower located at X,Y", which corresponds to the TA positioning currently being implemented. - other SI-units GAD element encodings are so far not implemented. Add encoding and decoding tests. In gsm/protocol/gsm_23_032.h are the raw coding structs as defined in 3GPP TS 23.032. In gsm/gad.h are structs carrying consistent units based on meters and degrees, for convenient / less error prone handling of GAD data, and for human readable representations of the GAD data. The separation of the two is desirable because OsmoBSC will receive GAD data from OsmoSMLC on the Lb interface, and pass on this data to the MSC via the A interface. It is better to pass the GAD data as-is without de/encoding. Change-Id: I7a9dd805a91b1ebb6353bde0cd169218acbf223c
Diffstat (limited to 'include/Makefile.am')
-rw-r--r--include/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/include/Makefile.am b/include/Makefile.am
index a6341f1a..fc1eec33 100644
--- a/include/Makefile.am
+++ b/include/Makefile.am
@@ -92,6 +92,7 @@ nobase_include_HEADERS = \
osmocom/coding/gsm0503_interleaving.h \
osmocom/coding/gsm0503_coding.h \
osmocom/coding/gsm0503_amr_dtx.h \
+ osmocom/gsm/gad.h \
osmocom/gsm/gsm0808.h \
osmocom/gsm/gsm29205.h \
osmocom/gsm/gsm0808_utils.h \
@@ -115,6 +116,7 @@ nobase_include_HEADERS = \
osmocom/gsm/l1sap.h \
osmocom/gsm/oap.h \
osmocom/gsm/oap_client.h \
+ osmocom/gsm/protocol/gsm_23_032.h \
osmocom/gsm/protocol/gsm_03_40.h \
osmocom/gsm/protocol/gsm_03_41.h \
osmocom/gsm/protocol/gsm_04_08.h \