aboutsummaryrefslogtreecommitdiffstats
path: root/include/Makefile.am
diff options
context:
space:
mode:
authorMax <max.suraev@fairwaves.co>2014-06-04 19:07:41 +0200
committerSylvain Munaut <tnt@246tNt.com>2014-06-16 14:33:27 +0200
commit537770174625cd3ce5c165ab0289aef5d974dac3 (patch)
treefaf473b5c47f98bca1ffc76f4d501ad613c1748f /include/Makefile.am
parent12ba778afdb797575e05284decd34cf2c27e3647 (diff)
core: Add generic LE/BE load/store uint type convertors and use them in msgb
Submitted-by: Max <max.suraev@fairwaves.co> Signed-off-by: Sylvain Munaut <tnt@246tNt.com>
Diffstat (limited to 'include/Makefile.am')
-rw-r--r--include/Makefile.am7
1 files changed, 7 insertions, 0 deletions
diff --git a/include/Makefile.am b/include/Makefile.am
index b0359064..48ca7ea2 100644
--- a/include/Makefile.am
+++ b/include/Makefile.am
@@ -2,6 +2,9 @@ nobase_include_HEADERS = \
osmocom/codec/codec.h \
osmocom/core/application.h \
osmocom/core/backtrace.h \
+ osmocom/core/bit16gen.h \
+ osmocom/core/bit32gen.h \
+ osmocom/core/bit64gen.h \
osmocom/core/bits.h \
osmocom/core/bitvec.h \
osmocom/core/conv.h \
@@ -107,6 +110,10 @@ endif
noinst_HEADERS = osmocom/core/timer_compat.h
+osmocom/core/bit%gen.h: osmocom/core/bitXXgen.h.tpl
+ $(AM_V_GEN)$(MKDIR_P) $(dir $@)
+ $(AM_V_GEN)sed -e's/XX/$*/g' $< > $@
+
osmocom/core/crc%gen.h: osmocom/core/crcXXgen.h.tpl
$(AM_V_GEN)$(MKDIR_P) $(dir $@)
$(AM_V_GEN)sed -e's/XX/$*/g' $< > $@