aboutsummaryrefslogtreecommitdiffstats
path: root/include/Makefile.am
diff options
context:
space:
mode:
authorPau Espin Pedrol <pespin@sysmocom.de>2018-02-26 18:03:44 +0100
committerHarald Welte <laforge@gnumonks.org>2018-02-27 15:44:29 +0000
commit726ba36201226fe1b0e768b27cb67bce45443df5 (patch)
treefae3ea20080850a97ecd9a39e8ca6887a9a7458c /include/Makefile.am
parentcc81722736c9bd2a0a16cf2247eda6b82074a198 (diff)
core: Add timespec helper macros and make timer_compat.h public
If a monotonic clock must be used, then the clock_gettime API is used which uses timespec structures. Linux systems by default don't provide helpers to calculate time using timespecs, so let's add them here. Let's also make this header public so these helpers can be used in other projects using libosmocore (expected user: libosmo-netif). Change-Id: I45fc993b9bb0a343763238bf463c8640f47b00f1
Diffstat (limited to 'include/Makefile.am')
-rw-r--r--include/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/Makefile.am b/include/Makefile.am
index f95d90c7..8b05f80b 100644
--- a/include/Makefile.am
+++ b/include/Makefile.am
@@ -47,6 +47,7 @@ nobase_include_HEADERS = \
osmocom/core/strrb.h \
osmocom/core/talloc.h \
osmocom/core/timer.h \
+ osmocom/core/timer_compat.h \
osmocom/core/utils.h \
osmocom/core/write_queue.h \
osmocom/crypt/auth.h \
@@ -148,7 +149,6 @@ nobase_include_HEADERS += \
endif
noinst_HEADERS = \
- osmocom/core/timer_compat.h \
osmocom/gsm/kasumi.h osmocom/gsm/gea.h
osmocom/core/bit%gen.h: osmocom/core/bitXXgen.h.tpl