aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorSylvain Munaut <tnt@246tNt.com>2010-07-25 16:16:42 +0200
committerSylvain Munaut <tnt@246tNt.com>2010-07-25 16:16:42 +0200
commitf23ababfb2160f3189c19898c1ae5a987be1ba47 (patch)
treeef99461e70204871ec11c16d25515523ff3ecf95 /configure.in
parent27af075e1e93ba9cd69a345fa590c50e96f8d9c6 (diff)
build: Use AS_HELP_STRING macro to format the ./configure --help better
Signed-off-by: Sylvain Munaut <tnt@246tNt.com>
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in20
1 files changed, 16 insertions, 4 deletions
diff --git a/configure.in b/configure.in
index e3e178c0..140fdc2f 100644
--- a/configure.in
+++ b/configure.in
@@ -35,22 +35,34 @@ dnl Generate the output
AM_CONFIG_HEADER(config.h)
AC_ARG_ENABLE(talloc,
- [ --disable-talloc Disable building talloc memory allocator ],
+ [AS_HELP_STRING(
+ [--disable-talloc],
+ [Disable building talloc memory allocator]
+ )],
[enable_talloc=0], [enable_talloc=1])
AM_CONDITIONAL(ENABLE_TALLOC, test "x$enable_talloc" = "x1")
AC_ARG_ENABLE(plugin,
- [ --disable-plugin Disable support for dlopen plugins ],
+ [AS_HELP_STRING(
+ [--disable-plugin],
+ [Disable support for dlopen plugins],
+ )],
[enable_plugin=0], [enable_plugin=1])
AM_CONDITIONAL(ENABLE_PLUGIN, test "x$enable_plugin" = "x1")
AC_ARG_ENABLE(tests,
- [ --disable-tests Disable building test programs ],
+ [AS_HELP_STRING(
+ [--disable-tests],
+ [Disable building test programs]
+ )],
[enable_tests=0], [enable_tests=1])
AM_CONDITIONAL(ENABLE_TESTS, test "x$enable_tests" = "x1")
AC_ARG_ENABLE(vty,
- [ --disable-vty Disable building VTY telnet interface ],
+ [AS_HELP_STRING(
+ [--disable-vty],
+ [Disable building VTY telnet interface]
+ )],
[enable_vty=0], [enable_vty=1])
AM_CONDITIONAL(ENABLE_VTY, test "x$enable_vty" = "x1")