aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorHarald Welte <laforge@gnumonks.org>2010-03-07 20:24:30 +0100
committerHarald Welte <laforge@gnumonks.org>2010-03-07 20:24:30 +0100
commitcbb29f7c94ad2a7cb0ebe7d43cbef5fb9d11d62e (patch)
tree83b5be0646f64acc70d4cb6e6826029f6dd57311 /configure.in
parentd3ff15fc818887be3720265b297ca7f1ec28c458 (diff)
add --disable-talloc option to build without talloc support
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index a5c5f6b3..11541967 100644
--- a/configure.in
+++ b/configure.in
@@ -30,6 +30,12 @@ AC_SUBST(SYMBOL_VISIBILITY)
dnl Generate the output
AM_CONFIG_HEADER(config.h)
+AC_ARG_ENABLE(talloc,
+ [ --disable-talloc Support message buffer ],
+ [enable_talloc=0], [enable_talloc=1])
+
+AM_CONDITIONAL(ENABLE_TALLOC, test "x$enable_talloc" = "x1")
+
AC_OUTPUT(
libosmocore.pc
include/osmocore/Makefile