aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorHarald Welte <laforge@gnumonks.org>2010-06-30 19:43:11 +0200
committerHarald Welte <laforge@gnumonks.org>2010-06-30 19:43:11 +0200
commitb9ce51c5fd9773694856802a175efdd9b37a2242 (patch)
tree5a920bcab6c518da0887500731380fdee325d195 /configure.in
parente34a94054227bb8b21a6082f7954fea980e2fead (diff)
Add support for plugins (and specifically GPRS encryption plugins)
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index b5eea6b1..e3e178c0 100644
--- a/configure.in
+++ b/configure.in
@@ -39,6 +39,11 @@ AC_ARG_ENABLE(talloc,
[enable_talloc=0], [enable_talloc=1])
AM_CONDITIONAL(ENABLE_TALLOC, test "x$enable_talloc" = "x1")
+AC_ARG_ENABLE(plugin,
+ [ --disable-plugin Disable support for dlopen plugins ],
+ [enable_plugin=0], [enable_plugin=1])
+AM_CONDITIONAL(ENABLE_PLUGIN, test "x$enable_plugin" = "x1")
+
AC_ARG_ENABLE(tests,
[ --disable-tests Disable building test programs ],
[enable_tests=0], [enable_tests=1])
@@ -55,6 +60,7 @@ AC_OUTPUT(
libosmovty.pc
include/osmocom/Makefile
include/osmocom/vty/Makefile
+ include/osmocom/crypt/Makefile
include/osmocore/Makefile
include/osmocore/protocol/Makefile
include/Makefile