aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorHarald Welte <laforge@gnumonks.org>2017-01-15 17:52:30 +0100
committerHarald Welte <laforge@gnumonks.org>2017-01-15 18:04:02 +0100
commit1c67e754b8e5bd25f966152d9bca347dbc75ec4e (patch)
tree1c1737c1a92254fa82163472ba186d00a8dca6ac /configure.ac
parent2f0b0c955b4031a9dd95829322455cf883d40f53 (diff)
configure.ac: Introduce --disable-ctrl
Using --disable-ctrl, one can disable the building of libosmoctrl. The 'embedded' target will also automaticall disable ctrl. Change-Id: I6912396338c5b23ae860fef2a55854d6df9a579d
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index ec03c264..bbbe241e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -185,6 +185,14 @@ AC_ARG_ENABLE(gb,
[enable_gb=$enableval], [enable_gb="yes"])
AM_CONDITIONAL(ENABLE_GB, test x"$enable_gb" = x"yes")
+AC_ARG_ENABLE(ctrl,
+ [AS_HELP_STRING(
+ [--disable-ctrl],
+ [Disable building CTRL library],
+ )],
+ [enable_ctrl=$enableval], [enable_ctrl="yes"])
+AM_CONDITIONAL(ENABLE_CTRL, test x"$enable_ctrl" = x"yes")
+
AC_ARG_ENABLE(embedded,
[AS_HELP_STRING(
[--enable-embedded],
@@ -198,6 +206,7 @@ then
AM_CONDITIONAL(ENABLE_MSGFILE, false)
AM_CONDITIONAL(ENABLE_SERIAL, false)
AM_CONDITIONAL(ENABLE_VTY, false)
+ AM_CONDITIONAL(ENABLE_CTRL, false)
AM_CONDITIONAL(ENABLE_UTILITIES, false)
AM_CONDITIONAL(ENABLE_GB, false)
AC_DEFINE([PANIC_INFLOOP],[1],[Use infinite loop on panic rather than fprintf/abort])