aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorHolger Hans Peter Freyther <holger@moiji-mobile.com>2014-11-14 15:06:09 +0100
committerHolger Hans Peter Freyther <holger@moiji-mobile.com>2014-11-14 15:06:09 +0100
commit18bcc8ab6214e92539370eb3c5b601f18def4dde (patch)
tree86aa13dfd5b5a8b749c713d289858553d07d91ce /configure.ac
parent8497b0a78671e09015ec2cb40f0a21cae7baf5ad (diff)
pcsc: Allow to disable the PCSC dependency
* PCSC is enabled by default * --enable-pcsc is enabling it * --disable-pcscis disabling it * Fix the makefile of the utilities to not build pcsc and use the right header files/libraries.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 6 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 80e2bccb..ef74932b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -84,13 +84,15 @@ AC_CONFIG_HEADER(config.h)
AC_ARG_ENABLE([pcsc], [AS_HELP_STRING([--disable-pcsc], [Build without PC/SC support])],
[
- osmo_ac_have_pcsc=$enableval
+ enable_pcsc=$enableval
],
[
- PKG_CHECK_MODULES(PCSC, libpcsclite)
- osmo_ac_have_pcsc="yes"
+ enable_pcsc="yes"
])
-AM_CONDITIONAL(ENABLE_PCSC, test "x$osmo_ac_have_pcsc" = "xyes")
+if test "x$enable_pcsc" = "xyes" ; then
+ PKG_CHECK_MODULES(PCSC, libpcsclite)
+fi
+AM_CONDITIONAL(ENABLE_PCSC, test "x$enable_pcsc" = "xyes")
AC_ARG_ENABLE(talloc,
[AS_HELP_STRING(