aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorHarald Welte <laforge@gnumonks.org>2011-08-17 19:33:06 +0200
committerHarald Welte <laforge@gnumonks.org>2011-08-17 19:33:06 +0200
commit21e73c2597da30e6e5b0acb808cd27fb21e8bbbd (patch)
treec0adafcdad96e8ef353950914a83a111144afd40 /configure.ac
parent500c7ceffd18410001be8051bd819bf24330f5c3 (diff)
Integrate doxygen documentation building into autoconf/automake process
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index b95c8cc0..a77e3e89 100644
--- a/configure.ac
+++ b/configure.ac
@@ -20,6 +20,9 @@ dnl checks for header files
AC_HEADER_STDC
AC_CHECK_HEADERS(execinfo.h sys/select.h sys/socket.h syslog.h ctype.h)
+AC_PATH_PROG(DOXYGEN,doxygen,false)
+AM_CONDITIONAL(HAVE_DOXYGEN, test $DOXYGEN != false)
+
# The following test is taken from WebKit's webkit.m4
saved_CFLAGS="$CFLAGS"
CFLAGS="$CFLAGS -fvisibility=hidden "