aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorHarald Welte <laforge@osmocom.org>2019-12-15 19:13:26 +0100
committerHarald Welte <laforge@osmocom.org>2019-12-16 00:17:27 +0100
commitda432cdc35ddc3e2e1374f7fc46210b4a92e6f54 (patch)
tree2aea6b55f7d66bc517fbe4464de0b88b793fc521 /Makefile.am
parent7d0fe2ae6f9892faac0fc4374573869e6edf325e (diff)
libosmocore libusb integration
Osmocom applications typically use libosmocore select.[ch] event loop code as their main event dispatch mechanism. When they want to deal with libusb in a non-blocking/asynchronous way, they need to integrate libusb into that select(). The new libosmousb is doing exactly that: Providing a shared utility library for Osmocom programs that wish to use libusb. This is useful for example in simtrace2 host utilitie as well as osmo-e1d. Change-Id: I656a1a38cbb5b1f3a9145d2869d3b4d0adefcae3 Closes: OS#4299
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 7b6ba0ae..7390f982 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,11 +1,12 @@
ACLOCAL_AMFLAGS = -I m4
AM_CPPFLAGS = $(all_includes) -I$(top_srcdir)/include
-SUBDIRS = include src src/vty src/codec src/gsm src/coding src/gb src/ctrl src/sim src/pseudotalloc utils tests
+SUBDIRS = include src src/vty src/codec src/gsm src/coding src/gb src/ctrl src/sim src/pseudotalloc src/usb utils tests
pkgconfigdir = $(libdir)/pkgconfig
pkgconfig_DATA = libosmocore.pc libosmocodec.pc libosmovty.pc libosmogsm.pc \
- libosmogb.pc libosmoctrl.pc libosmocoding.pc libosmosim.pc
+ libosmogb.pc libosmoctrl.pc libosmocoding.pc libosmosim.pc \
+ libosmousb.pc
aclocaldir = $(datadir)/aclocal
dist_aclocal_DATA = m4/osmo_ac_code_coverage.m4 \