aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorHarald Welte <laforge@gnumonks.org>2018-05-26 17:25:11 +0200
committerHarald Welte <laforge@gnumonks.org>2018-05-26 21:58:15 +0200
commitb4186824c20cbb5a18963d737f47718aed791e33 (patch)
tree419bd2c22ef95cc93e7c6533e498e8beb02d0de4 /Makefile.am
parented6057841dd094f95efebbeae51a85bd0879463f (diff)
ctrl: Add doxygen API documentation; generate html from it
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 8 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 60ec1f88..de5eb35d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -35,6 +35,7 @@ $(html_DATA): $(top_builddir)/doc/core/html/index.html \
$(top_builddir)/doc/vty/html/index.html \
$(top_builddir)/doc/codec/html/index.html \
$(top_builddir)/doc/coding/html/index.html \
+ $(top_builddir)/doc/ctrl/html/index.html \
$(top_builddir)/doc/gb/html/index.html
cd $(top_builddir)/doc && tar cf html.tar */html
@@ -62,6 +63,11 @@ $(top_builddir)/doc/coding/html/index.html: Doxyfile.coding
mkdir -p doc/coding
$(DOXYGEN) Doxyfile.coding
+$(top_builddir)/doc/ctrl/html/index.html: $(SOURCES) Doxyfile.ctrl
+ @rm -rf doc/ctrl
+ mkdir -p doc/ctrl
+ $(DOXYGEN) Doxyfile.ctrl
+
$(top_builddir)/doc/gb/html/index.html: $(SOURCES) Doxyfile.gb
@rm -rf doc/gb
mkdir -p doc/gb
@@ -71,9 +77,9 @@ install-data-hook:
cd $(DESTDIR)$(htmldir) && tar xf html.tar && rm -f html.tar
uninstall-hook:
- cd $(DESTDIR)$(htmldir) && rm -rf {core,gsm,vty,codec,coding,gb}
+ cd $(DESTDIR)$(htmldir) && rm -rf {core,gsm,vty,codec,coding,ctrl,gb}
-DX_CLEAN = doc/{core,gsm,vty,codec,coding,gb}/html/search/* doc/{core,gsm,vty,codec,coding,gb}/{html,latex}/* doc/html.tar doc/{core,gsm,vty,codec,coding,gb}/doxygen_sqlite3.db doc/*.tag
+DX_CLEAN = doc/{core,gsm,vty,codec,coding,ctrl,gb}/html/search/* doc/{core,gsm,vty,codec,coding,ctrl,gb}/{html,latex}/* doc/html.tar doc/{core,gsm,vty,codec,coding,ctrl,gb}/doxygen_sqlite3.db doc/*.tag
endif
MOSTLYCLEANFILES = $(DX_CLEAN)