aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorHolger Hans Peter Freyther <holger@moiji-mobile.com>2014-09-08 07:23:33 +0200
committerHolger Hans Peter Freyther <holger@moiji-mobile.com>2014-09-23 16:27:13 +0200
commit050b9bf5b91238da074a0b26391eb1048f44e7a7 (patch)
tree16d0b66ae9f860d3ef6e10f0883eb750628edae3
parentde883e7f6cfb71f46921d6ef7564b24aeecd6f2c (diff)
Revert "logging: Add ability to save/print current log filters"
This reverts commit fb84f325b8e672ba7ca1a961f4ef01f4d011e33d.
-rw-r--r--include/osmocom/core/logging.h16
-rw-r--r--src/Makefile.am2
-rw-r--r--src/vty/logging_vty.c8
3 files changed, 3 insertions, 23 deletions
diff --git a/include/osmocom/core/logging.h b/include/osmocom/core/logging.h
index 4c893ac4..3c5e7b15 100644
--- a/include/osmocom/core/logging.h
+++ b/include/osmocom/core/logging.h
@@ -95,17 +95,6 @@ struct log_target;
typedef int log_filter(const struct log_context *ctx,
struct log_target *target);
-struct log_info;
-struct vty;
-
-typedef void log_print_filters(struct vty *vty,
- const struct log_info *info,
- const struct log_target *tgt);
-
-typedef void log_save_filters(struct vty *vty,
- const struct log_info *info,
- const struct log_target *tgt);
-
/*! \brief Logging configuration, passed to \ref log_init */
struct log_info {
/* \brief filter callback function */
@@ -117,11 +106,6 @@ struct log_info {
unsigned int num_cat;
/*! \brief total number of user categories (not library) */
unsigned int num_cat_user;
-
- /* \brief filter saving function */
- log_save_filters *save_fn;
- /* \brief filter saving function */
- log_print_filters *print_fn;
};
/*! \brief Type of logging target */
diff --git a/src/Makefile.am b/src/Makefile.am
index f2b1b838..841f6725 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -1,6 +1,6 @@
# This is _NOT_ the library release version, it's an API version.
# Please read Chapter 6 "Library interface versions" of the libtool documentation before making any modification
-LIBVERSION=5:0:0
+LIBVERSION=4:0:0
AM_CFLAGS = -Wall $(all_includes) -I$(top_srcdir)/include -I$(top_builddir)/include
diff --git a/src/vty/logging_vty.c b/src/vty/logging_vty.c
index 47877fe9..64e49d7e 100644
--- a/src/vty/logging_vty.c
+++ b/src/vty/logging_vty.c
@@ -252,9 +252,7 @@ static void vty_print_logtarget(struct vty *vty, const struct log_info *info,
tgt->filter_map & LOG_FILTER_ALL ? "Enabled" : "Disabled",
VTY_NEWLINE);
- /* print application specific filters */
- if (info->print_fn)
- info->print_fn(vty, info, tgt);
+ /* FIXME: print application specific filters */
}
#define SHOW_LOG_STR "Show current logging configuration\n"
@@ -619,9 +617,7 @@ static int config_write_log_single(struct vty *vty, struct log_target *tgt)
vty_out(vty, " logging filter all %u%s",
tgt->filter_map & LOG_FILTER_ALL ? 1 : 0, VTY_NEWLINE);
- /* save filters outside of libosmocore, i.e. in app code */
- if (osmo_log_info->save_fn)
- osmo_log_info->save_fn(vty, osmo_log_info, tgt);
+ /* FIXME: how to do this for filters outside of libosmocore? */
vty_out(vty, " logging color %u%s", tgt->use_color ? 1 : 0,
VTY_NEWLINE);