aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorHarald Welte <laforge@gnumonks.org>2017-04-03 17:37:10 +0200
committerHarald Welte <laforge@gnumonks.org>2017-04-10 10:41:16 +0200
commit2d3a709527c3ba3228d8c5aa14a236b5952079b9 (patch)
tree2e13bddad4c9466bfc81155561a9475c4ef707f2 /configure.ac
parentc96db7fa585d169eff600ebc291d45b427a6cb16 (diff)
Add new 'osmo_ss7' SS7 core code with M3UA, ASP/AS FSM, ...
This is what aims to be a rather complete/proper implementation of the SIGTRAN + SS7 protocol suite. It has proper abstraction between the layers with primitives, finite state machines for things like the AS and ASP state machines, support for point code routing, etc. What's not implemented at this point: * re-integration of pre-existing SUA (pending) * actual MTP2 and physical E1/T1 link support * different trafic modes like broadcast/fail-over/load-balance Change-Id: I375eb80f01acc013094851d91d1d3333ebc12bc7
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 12 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 4c3c937..116e168 100644
--- a/configure.ac
+++ b/configure.ac
@@ -29,6 +29,17 @@ PKG_PROG_PKG_CONFIG([0.20])
PKG_CHECK_MODULES(LIBOSMOCORE, libosmocore >= 0.3.0)
PKG_CHECK_MODULES(LIBOSMONETIF, libosmo-netif >= 0.0.6)
+old_LIBS=$LIBS
+AC_SEARCH_LIBS([sctp_send], [sctp], [
+ AC_DEFINE(HAVE_LIBSCTP, 1, [Define 1 to enable SCTP support])
+ AC_SUBST(HAVE_LIBSCTP, [1])
+ if test -n "$ac_lib"; then
+ AC_SUBST(LIBSCTP_LIBS, [-l$ac_lib])
+ fi
+ ], [
+ AC_MSG_ERROR([sctp_send not found in searched libs])])
+LIBS=$old_LIBS
+
# The following test is taken from WebKit's webkit.m4
saved_CFLAGS="$CFLAGS"
CFLAGS="$CFLAGS -fvisibility=hidden "
@@ -56,5 +67,6 @@ AC_OUTPUT(
tests/mtp/Makefile
tests/m2ua/Makefile
tests/sigtran/Makefile
+ tests/ss7/Makefile
Makefile)