aboutsummaryrefslogtreecommitdiffstats
path: root/tests/osmo-pcap-test/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'tests/osmo-pcap-test/configure.ac')
-rw-r--r--tests/osmo-pcap-test/configure.ac28
1 files changed, 28 insertions, 0 deletions
diff --git a/tests/osmo-pcap-test/configure.ac b/tests/osmo-pcap-test/configure.ac
new file mode 100644
index 0000000..0d496db
--- /dev/null
+++ b/tests/osmo-pcap-test/configure.ac
@@ -0,0 +1,28 @@
+AC_INIT(osmo-pcap-test, 0.0.1, pablo@gnumonks.org)
+AC_CONFIG_AUX_DIR([build-aux])
+
+AC_CANONICAL_HOST
+AC_CONFIG_MACRO_DIR([m4])
+AM_INIT_AUTOMAKE([-Wall foreign subdir-objects
+ tar-pax no-dist-gzip dist-bzip2 1.6])
+
+dnl kernel style compile messages
+m4_ifdef([AM_SILENT_RULES], [AM_SILENT_RULES([yes])])
+
+PKG_CHECK_MODULES(LIBOSMOCORE, libosmocore >= 0.3.0)
+
+AC_PROG_CC
+AC_DISABLE_STATIC
+AM_PROG_LIBTOOL
+AC_PROG_INSTALL
+AC_PROG_LN_S
+AM_PROG_LEX
+AC_PROG_YACC
+
+case "$host" in
+*-*-linux*) ;;
+*) AC_MSG_ERROR([Linux only, dude!]);;
+esac
+
+AC_CONFIG_FILES([Makefile])
+AC_OUTPUT