aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 3 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index cd91a6f..19f7d18 100644
--- a/configure.ac
+++ b/configure.ac
@@ -45,7 +45,9 @@ old_LIBS=$LIBS
AC_SEARCH_LIBS([sctp_send], [sctp], [
AC_DEFINE(HAVE_LIBSCTP, 1, [Define 1 to enable SCTP support])
AC_SUBST(HAVE_LIBSCTP, [1])
- AC_SUBST(LIBSCTP_LIBS, [-l$ac_lib])
+ if test -n "$ac_lib"; then
+ AC_SUBST(LIBSCTP_LIBS, [-l$ac_lib])
+ fi
], [
AC_MSG_ERROR([sctp_send not found in searched libs])])
LIBS=$old_LIBS