aboutsummaryrefslogtreecommitdiffstats
path: root/utils/Makefile.am
diff options
context:
space:
mode:
authorPau Espin Pedrol <pespin@sysmocom.de>2022-12-21 17:12:22 +0100
committerPau Espin Pedrol <pespin@sysmocom.de>2022-12-22 13:56:26 +0100
commita1c9fbfabce809a3dba869e37109021d11c1de2f (patch)
tree5c760d5b52d05c1f8f07eb3a125af8a82479fec7 /utils/Makefile.am
parentc0691ad3fd8b7a298ebec9abce650172443bf331 (diff)
Introduce utils/osmo-amr-inspect program2023q1
This program allows inspecting a list of AMR PDUs in hexstring format present in a text file. This allows easily finding out the properties of the PDU as well as finding potential errors on the data. It also allows forcing decode in different formats (octet-aligned, bandwidth-efficient) in order to detect which may be the correct one. Related: SYS#6161 Change-Id: Iffa6cc2e5391b77e3097d4c3b8d3f5211427dbe2
Diffstat (limited to 'utils/Makefile.am')
-rw-r--r--utils/Makefile.am19
1 files changed, 19 insertions, 0 deletions
diff --git a/utils/Makefile.am b/utils/Makefile.am
new file mode 100644
index 0000000..5640190
--- /dev/null
+++ b/utils/Makefile.am
@@ -0,0 +1,19 @@
+AM_CPPFLAGS = -I$(top_srcdir)/include -I$(top_builddir)/include
+AM_CFLAGS = \
+ -Wall \
+ $(LIBOSMOCORE_CFLAGS) \
+ $(LIBOSMOCODEC_CFLAGS) \
+ $(LIBOSMOGSM_CFLAGS) \
+ $(TALLOC_CFLAGS) \
+ $(NULL)
+
+LDADD = \
+ $(LIBOSMOCORE_LIBS) \
+ $(LIBOSMOCODEC_LIBS) \
+ $(LIBOSMOGSM_LIBS) \
+ $(top_builddir)/src/libosmonetif.la \
+ $(NULL)
+
+noinst_PROGRAMS = osmo-amr-inspect
+
+osmo_amr_inspect_SOURCES = osmo-amr-inspect.c