aboutsummaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorHarald Welte <laforge@gnumonks.org>2018-06-29 10:57:24 +0200
committerHarald Welte <laforge@gnumonks.org>2018-06-29 10:57:24 +0200
commite2fbd3dee43bb3d47c53514200650db41b4f5ef7 (patch)
treeac734d1bdded7790705539f101ec0f6f3898013e /src/Makefile.am
parent7839556ca950f02e2dda48f8e10dd68e90266926 (diff)
remove "channel" layer
The "channel" layer on top of IPA client + server was introduced in 2011 but never used in any osmocom program/project so far. Contrary to the several other IPA multiplex related implementations in libosmo*, it did not deal properly with segmented IPA messages, i.e. where a single TCP segment (and hence recv/read call) does not contain a full IPA message. So rather than fixing it up and having yet another IPA related API in our libraries, let's remove it. Change-Id: I97c378750acb1637ee032fa88a968edf68d8979f
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am5
1 files changed, 1 insertions, 4 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 9dc5e46..9951ca4 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -6,15 +6,12 @@ AM_CPPFLAGS = -I$(top_srcdir)/include -I$(top_builddir)
AM_CFLAGS= -fPIC -Wall $(LIBOSMOCORE_CFLAGS) $(LIBOSMOABIS_CFLAGS) $(COVERAGE_CFLAGS) $(LIBSCTP_CFLAGS)
AM_LDFLAGS = $(COVERAGE_LDFLAGS)
-SUBDIRS = channel
-
lib_LTLIBRARIES = libosmonetif.la
-libosmonetif_la_LIBADD = channel/abis/libosmonetif-abis.la $(LIBOSMOCORE_LIBS) $(LIBSCTP_LIBS)
+libosmonetif_la_LIBADD = $(LIBOSMOCORE_LIBS) $(LIBSCTP_LIBS)
libosmonetif_la_LDFLAGS = -version-info $(LIBVERSION) -no-undefined
libosmonetif_la_SOURCES = amr.c \
- channel.c \
datagram.c \
ipa.c \
ipa_unit.c \