aboutsummaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorHarald Welte <laforge@gnumonks.org>2017-10-27 20:00:39 +0200
committerHarald Welte <laforge@gnumonks.org>2017-10-27 20:21:20 +0200
commitc2c8b5c557650a1842029fd081ffddca6db65af6 (patch)
treeca633cc2e798a13f71c9992dba97c6dfacaac2f9 /src/Makefile.am
parentc01033fcacd7b87cc9eb47279a5d40445d770c18 (diff)
Tag/Release Version 0.1.00.1.0
Short changelog: * Add Doxygen documentation * SCTP support in stream.c * new udp-test-client and udp-test-server programs * better / more verbose error handling in examples * new osmo_dgram_tx_set_local_{addr,port}() functions * use IPA definitions from libosmogsm, rather than repeating them * encode RTP header M field of RFC3550/4867 in OSMUX header * new osmo_stream_srv_link_set_nodelay() * new osmo_stream_srv_link_set_proto() * new osmo_stream_cli_set_nodelay() * new osmo_stream_cli_set_proto() * new osmo_stream_cli_set_local_addr() * new osmo_stream_cli_set_local_port() * new osmo_stream_cli_reconnect() * new osmo_stream_cli_open2() with reconnect argument * more vrebose osmux_snprintf() * remove mistaken reference to AGPL in rs232.c * fix memory leak in osmo_stream_srv_link_set_addr() * add osmo-pcap-test for SLL and Ethernet * extend osmux-test Change-Id: Ibf75fcd6643351ce3946faa155ae1db8c33a5e35
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 4bc481e..e647090 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -1,6 +1,6 @@
# This is _NOT_ the library release version, it's an API version.
# Please read Chapter 6 "Library interface versions" of the libtool documentation before making any modification
-LIBVERSION=3:0:0
+LIBVERSION=4:0:0
AM_CPPFLAGS = -I$(top_srcdir)/include -I$(top_builddir)
AM_CFLAGS= -fPIC -Wall $(LIBOSMOCORE_CFLAGS) $(LIBOSMOGSM_CFLAGS) $(LIBOSMOABIS_CFLAGS) $(COVERAGE_CFLAGS) $(LIBSCTP_CFLAGS)