aboutsummaryrefslogtreecommitdiffstats
path: root/examples/Makefile.am
diff options
context:
space:
mode:
authorPablo Neira Ayuso <pablo@gnumonks.org>2011-10-03 22:09:45 +0200
committerPablo Neira Ayuso <pablo@netfilter.org>2011-10-04 02:36:46 +0200
commit8bf16493f68fd53c6e14f1612caf7425c73b2f4d (patch)
tree3ec412622ca065b7d835f6cfbc953d8ea6b1546a /examples/Makefile.am
initial commit
Diffstat (limited to 'examples/Makefile.am')
-rw-r--r--examples/Makefile.am16
1 files changed, 16 insertions, 0 deletions
diff --git a/examples/Makefile.am b/examples/Makefile.am
new file mode 100644
index 0000000..981128b
--- /dev/null
+++ b/examples/Makefile.am
@@ -0,0 +1,16 @@
+INCLUDES = $(all_includes) -I$(top_srcdir)/include
+AM_CFLAGS=-Wall -g $(LIBOSMOCORE_CFLAGS) $(LIBOSMOGSM_CFLAGS) $(LIBOSMOABIS_CFLAGS) $(COVERAGE_CFLAGS)
+AM_LDFLAGS = $(COVERAGE_LDFLAGS)
+
+noinst_PROGRAMS = lapd-over-stream-client \
+ lapd-over-stream-server
+
+lapd_over_stream_client_SOURCES = lapd-over-stream-client.c
+lapd_over_stream_client_LDADD = $(top_builddir)/src/libosmonetif.la \
+ $(LIBOSMOCORE_LIBS) $(LIBOSMOGSM_LIBS) \
+ $(LIBOSMOABIS_LIBS)
+
+lapd_over_stream_server_SOURCES = lapd-over-stream-server.c
+lapd_over_stream_server_LDADD = $(top_builddir)/src/libosmonetif.la \
+ $(LIBOSMOCORE_LIBS) $(LIBOSMOGSM_LIBS) \
+ $(LIBOSMOABIS_LIBS)