aboutsummaryrefslogtreecommitdiffstats
path: root/examples/Makefile.am
diff options
context:
space:
mode:
authorPablo Neira Ayuso <pablo@gnumonks.org>2011-10-05 13:07:01 +0200
committerPablo Neira Ayuso <pablo@gnumonks.org>2011-10-05 13:43:21 +0200
commit602df1ec4cf103d8722260d3a4ba577c26fdf27a (patch)
tree9d23115456679c864f09b7b6a9a50ce835ac308a /examples/Makefile.am
parent7c20d4ef1e27974910c79979649fcba2a95ad1f8 (diff)
examples: add stream server/client example
This patch adds a couple of examples that allow chatting between the client and the server. For simplicity, the example only support one client.
Diffstat (limited to 'examples/Makefile.am')
-rw-r--r--examples/Makefile.am12
1 files changed, 11 insertions, 1 deletions
diff --git a/examples/Makefile.am b/examples/Makefile.am
index c1759e2..39e7207 100644
--- a/examples/Makefile.am
+++ b/examples/Makefile.am
@@ -3,7 +3,9 @@ AM_CFLAGS=-Wall -g $(LIBOSMOCORE_CFLAGS) $(LIBOSMOGSM_CFLAGS) $(LIBOSMOABIS_CFLA
AM_LDFLAGS = $(COVERAGE_LDFLAGS)
noinst_PROGRAMS = lapd-over-datagram-user \
- lapd-over-datagram-network
+ lapd-over-datagram-network \
+ stream-client \
+ stream-server
lapd_over_datagram_user_SOURCES = lapd-over-datagram-user.c
lapd_over_datagram_user_LDADD = $(top_builddir)/src/libosmonetif.la \
@@ -14,3 +16,11 @@ lapd_over_datagram_network_SOURCES = lapd-over-datagram-network.c
lapd_over_datagram_network_LDADD = $(top_builddir)/src/libosmonetif.la \
$(LIBOSMOCORE_LIBS) $(LIBOSMOGSM_LIBS) \
$(LIBOSMOABIS_LIBS)
+
+stream_client_SOURCES = stream-client.c
+stream_client_LDADD = $(top_builddir)/src/libosmonetif.la \
+ $(LIBOSMOCORE_LIBS) $(LIBOSMOGSM_LIBS)
+
+stream_server_SOURCES = stream-server.c
+stream_server_LDADD = $(top_builddir)/src/libosmonetif.la \
+ $(LIBOSMOCORE_LIBS) $(LIBOSMOGSM_LIBS)