aboutsummaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorHarald Welte <laforge@gnumonks.org>2018-08-06 11:11:44 +0200
committerHarald Welte <laforge@gnumonks.org>2018-08-06 11:11:44 +0200
commit646d1c82042d8e04e810e8532e462159aab6387b (patch)
tree5e794ef5934044f7da21be6e0b80668772b4491b /debian/rules
parent635984c5e1fd13e3fa6e605fcd7fc7ee0dfef7da (diff)
debian/rules: Don't overwrite .tarball-version
The .tarball-version file should contain the *source version* uniquely identifying the git commit, and not the Debian package name. With https://gerrit.osmocom.org/#/c/osmo-ci/+/10343/ there is a correct .tarball-version file in the .tar.xz of the nightly source packages. Change-Id: I8915ebbf7d3a64a9474e1aeb49b1d192a388ef53 Related: OS#3449
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules6
1 files changed, 1 insertions, 5 deletions
diff --git a/debian/rules b/debian/rules
index f0e00c5..4472bd1 100755
--- a/debian/rules
+++ b/debian/rules
@@ -15,17 +15,13 @@ export DEB_BUILD_MAINT_OPTIONS = hardening=+all
override_dh_strip:
dh_strip --dbg-package=libosmo-netif-dbg
-override_dh_autoreconf:
- echo $(VERSION) > .tarball-version
- dh_autoreconf
-
override_dh_install:
sed -i "/dependency_libs/ s/'.*'/''/" `find . -name '*.la'`
dh_install
override_dh_clean:
dh_clean
- rm -f tests/package.m4 tests/testsuite .version .tarball-version
+ rm -f tests/package.m4 tests/testsuite .version
override_dh_auto_test:
dh_auto_test || (find . -name testsuite.log -exec cat {} \; ; false)