aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorHarald Welte <laforge@osmocom.org>2021-02-11 15:38:18 +0100
committerHarald Welte <laforge@osmocom.org>2021-02-11 15:40:54 +0100
commitfa74cc5c68610ce49ddae58542f4a55c08d3fb5a (patch)
treef0051b7b3ec3e4a12dc5147e241abcd951695769 /configure.ac
parent637025b2f7e0e4c266a8c30025f56dd7a103e3bc (diff)
Don't depend on libosmo-abis (by default)
The only reason we have a libosmo-netif -> libosmo-abis dependency is the lapd examples whihc are built but not even installed. Let's build those only if --enable-lapd-examples is specified at the command line, and remove the dependency to libosmo-abis in all other cases. Change-Id: Ida8157cd9111b196e4bf08782c45d0e3d393f1c9 Closes: OS#4726
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 13 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 36c2f49..1b2a459 100644
--- a/configure.ac
+++ b/configure.ac
@@ -91,8 +91,19 @@ AM_CONFIG_HEADER(config.h)
PKG_CHECK_MODULES(LIBOSMOCORE, libosmocore >= 1.3.0)
PKG_CHECK_MODULES(LIBOSMOGSM, libosmogsm >= 1.3.0)
-dnl FIXME: We depend on libosmoabis by now until we can move LAPD code here
-PKG_CHECK_MODULES(LIBOSMOABIS, libosmoabis >= 0.6.0)
+
+AC_ARG_ENABLE([lapd_examples],
+ [AS_HELP_STRING(
+ [--enable-lapd-examples],
+ [Build some lapd examples]
+ )],
+ [lapd_examples=$enableval], [lapd_examples="no"])
+AS_IF([test "x$lapd_examples" = "xyes"], [
+ PKG_CHECK_MODULES(LIBOSMOABIS, libosmoabis >= 0.6.0)
+ AC_DEFINE([ENABLE_LAPD], [1], [Enable LAPD examples])
+])
+AM_CONDITIONAL(ENABLE_LAPD, test "x$lapd_examples" = "xyes")
+AC_SUBST(ENABLE_LAPD)
AC_ARG_ENABLE([libsctp], [AS_HELP_STRING([--disable-libsctp], [Do not enable socket multiaddr APIs requiring libsctp])],
[ENABLE_LIBSCTP=$enableval], [ENABLE_LIBSCTP="yes"])