aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorHarald Welte <laforge@gnumonks.org>2017-04-08 19:48:05 +0200
committerHarald Welte <laforge@gnumonks.org>2017-04-08 20:13:14 +0200
commitd0f9bd600c10615d9dbb6701001d491122a29aef (patch)
tree8cb0a22c0179359cbd8127fc65c056f0339608f2 /configure.ac
parent5fe77a4656f3590c343861ea96bcec18e370e437 (diff)
Add minimal doxygen documentation for stream + datagram modules
We should have doxygen documentation for all libosmo-* APIs. libosmo-netif is currently devoid of any API docs. Let's start with the stream and datagram socket related functions. Change-Id: I589a5e60d9df2b8a65fbaf68f80e3ae0039d8c2a
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 3994aff..8cd2238 100644
--- a/configure.ac
+++ b/configure.ac
@@ -63,6 +63,9 @@ LIBS=$old_LIBS
AC_CHECK_HEADERS(dahdi/user.h,,AC_MSG_WARN(DAHDI input driver will not be built))
+AC_PATH_PROG(DOXYGEN,doxygen,false)
+AM_CONDITIONAL(HAVE_DOXYGEN, test $DOXYGEN != false)
+
AC_OUTPUT(
libosmo-netif.pc
include/Makefile
@@ -75,4 +78,5 @@ AC_OUTPUT(
examples/Makefile
examples/channel/Makefile
tests/Makefile
+ Doxyfile
Makefile)