aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorAlexander Huemer <alexander.huemer@xx.vu>2012-12-06 23:09:31 +0100
committerSylvain Munaut <tnt@246tNt.com>2012-12-08 18:20:41 +0100
commit6a2078ff846a554ecde3bb3a528af3b970d64865 (patch)
tree0331cc6416cd0380cc29c1b2ec9edd1cc07cc2fd /configure.ac
parenta246a529fdd27d90c5cb641350ea5dc1df054a61 (diff)
rename configure.in -> configure.ac
configure.in is unsupported starting with automake 1.13
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac43
1 files changed, 43 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..b5b9481
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,43 @@
+AC_INIT([libosmo-crypt-a53],
+ m4_esyscmd([./git-version-gen .tarball-version]),
+ [openbsc-devel@lists.openbsc.org])
+
+AM_INIT_AUTOMAKE([dist-bzip2])
+
+dnl kernel style compile messages
+m4_ifdef([AM_SILENT_RULES], [AM_SILENT_RULES([yes])])
+
+dnl checks for programs
+AC_PROG_MAKE_SET
+AC_PROG_CC
+AC_PROG_INSTALL
+LT_INIT
+AC_PROG_LIBTOOL
+
+AC_CONFIG_MACRO_DIR([m4])
+
+dnl checks for header files
+AC_HEADER_STDC
+AC_CHECK_HEADERS(execinfo.h sys/select.h)
+
+# The following test is taken from WebKit's webkit.m4
+saved_CFLAGS="$CFLAGS"
+CFLAGS="$CFLAGS -fvisibility=hidden "
+AC_MSG_CHECKING([if ${CC} supports -fvisibility=hidden])
+AC_COMPILE_IFELSE([char foo;],
+ [ AC_MSG_RESULT([yes])
+ SYMBOL_VISIBILITY="-fvisibility=hidden"],
+ AC_MSG_RESULT([no]))
+CFLAGS="$saved_CFLAGS"
+AC_SUBST(SYMBOL_VISIBILITY)
+
+dnl Generate the output
+AM_CONFIG_HEADER(config.h)
+
+AC_OUTPUT(
+ libosmo-crypt-a53.pc
+ include/Makefile
+ include/osmocom/Makefile
+ include/osmocom/crypt/Makefile
+ src/Makefile
+ Makefile)