aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorHarald Welte <laforge@gnumonks.org>2010-06-30 20:35:55 +0200
committerHarald Welte <laforge@gnumonks.org>2010-06-30 20:38:05 +0200
commit6c0803938d9a2cd3e544f33ec3318372bd43744e (patch)
treeeceda7fd55e01ccb55fa743224656bb00a52b99d /Makefile.am
parent73998b6cf33f5adabb42bde4bf77a9445d685bd8 (diff)
Add autotools magic
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am14
1 files changed, 14 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..65a9de0
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,14 @@
+AUTOMAKE_OPTIONS = foreign dist-bzip2 1.6
+ACLOCAL_AMFLAGS = -I m4
+
+INCLUDES = $(all_includes) -I$(top_srcdir)/include
+SUBDIRS = include src
+
+pkgconfigdir = $(libdir)/pkgconfig
+pkgconfig_DATA = libosmo-crypt-a53.pc
+
+BUILT_SOURCES = $(top_srcdir)/.version
+$(top_srcdir)/.version:
+ echo $(VERSION) > $@-t && mv $@-t $@
+dist-hook:
+ echo $(VERSION) > $(distdir)/.tarball-version