aboutsummaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@flameeyes.eu>2012-06-30 15:22:59 -0700
committerHarald Welte <laforge@gnumonks.org>2012-07-01 07:40:36 +0200
commit05819cebc43bf65813aa4997eedc64c94b25ff97 (patch)
treec0025840c86b721337bb175d032733df1ff0e197 /src/Makefile.am
parent3dfe8bf80cee819e98618c03eb503a79830c2f61 (diff)
build: avoid using a convenience library for the input subdirectory.
automake is well capable of building sources present in sub-directory without requiring a recursion, so there is no reason to use a non-installed library just for the extra files. Signed-off-by: Diego Elio Pettenò <flameeyes@flameeyes.eu>
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am12
1 files changed, 9 insertions, 3 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 2155a76..a13223e 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -1,4 +1,4 @@
-SUBDIRS=input trau
+SUBDIRS=trau
# This is _NOT_ the library release version, it's an API version.
# Please read Chapter 6 "Library interface versions" of the libtool documentation before making any modification
@@ -10,10 +10,16 @@ AM_LDFLAGS = $(LIBOSMOCORE_LIBS) $(LIBOSMOGSM_LIBS) $(LIBOSMOVTY_LIBS) $(COVERAG
lib_LTLIBRARIES = libosmoabis.la
-libosmoabis_la_LIBADD = input/libosmoabis-input.la
libosmoabis_la_SOURCES = init.c \
e1_input.c \
e1_input_vty.c \
ipa_proxy.c \
subchan_demux.c \
- trau_frame.c
+ trau_frame.c \
+ input/dahdi.c \
+ input/hsl.c \
+ input/ipa.c \
+ input/ipaccess.c \
+ input/lapd.c \
+ input/misdn.c \
+ input/rs232.c