aboutsummaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorPablo Neira Ayuso <pablo@gnumonks.org>2012-08-22 16:43:59 +0200
committerPablo Neira Ayuso <pablo@netfilter.org>2012-08-30 21:50:31 +0200
commit953060001d2cb6ef86f432a79599da2951780ef7 (patch)
tree0e03bdc1e9d95ffae8d3c29e559c2a644d049929 /src/Makefile.am
parent7ed92581ee20b77911171355cf1d40c617a0b44b (diff)
input: add generic PCAP interface for LAPD
This patch allows you to create PCAP traces between the BSC and BTS including the LAPD frames. Useful for debugging communication issues. So far, it was only possible to create layer 3 traces containing OML/RSL. LAPD traces can be also interesting to debug communication issues between the BSC and the BTS. To enable PCAP of LAPD, you only have to invoke: li->pcap_fd = osmo_pcap_lapd_open("/tmp/file.pcap", 0600); By default, li->pcap_fd is set to -1 which means disabled. openBSC needs a patch to replace all usage of e1_set_pcap_fd by osmo_pcap_lapd_open.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index cf58aaa..01f0913 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -23,6 +23,7 @@ libosmoabis_la_SOURCES = init.c \
input/ipa.c \
input/ipaccess.c \
input/lapd.c \
+ input/lapd_pcap.c \
input/misdn.c \
input/rs232.c