aboutsummaryrefslogtreecommitdiffstats
path: root/debian
diff options
context:
space:
mode:
authorEric Butler <eric@codebutler.com>2012-08-14 20:56:26 -0700
committerEric Butler <eric@codebutler.com>2012-08-14 20:56:26 -0700
commitd11a5c110355f86c7673777632cb797bf20722eb (patch)
tree6dd4683376536d5d83839cc1b90480c1ae5c08cc /debian
parent91ffa2b5c1acf319b1c0e8f4a7f28aad63de7710 (diff)
Use package version since git info won't be available.
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog6
-rwxr-xr-xdebian/rules8
2 files changed, 14 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 661ff9e..faca1e6 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+libosmo-abis (0.1.3+git3-1) precise; urgency=low
+
+ * Fix version issue.
+
+ -- Eric Butler <eric@codebutler.com> Tue, 14 Aug 2012 20:50:50 -0700
+
libosmo-abis (0.1.3+git3) precise; urgency=low
Created new Ubuntu package.
diff --git a/debian/rules b/debian/rules
index 689c523..26d2880 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,8 +1,16 @@
#!/usr/bin/make -f
+DEBIAN := $(shell dpkg-parsechangelog | grep ^Version: | cut -d' ' -f2)
+DEBVERS := $(shell echo '$(DEBIAN)' | cut -d- -f1)
+VERSION := $(shell echo '$(DEBVERS)' | sed -e 's/[+-].*//' -e 's/~//g')
+
CFLAGS = -Wall -g
export DH_VERBOSE=1
%:
dh --with autoreconf $@ --fail-missing
+
+override_dh_autoreconf:
+ echo $(VERSION) > .tarball-version
+ dh_autoreconf