aboutsummaryrefslogtreecommitdiffstats
path: root/debian
diff options
context:
space:
mode:
authorHolger Hans Peter Freyther <zecke@selfish.org>2013-02-13 20:12:36 +0100
committerHolger Hans Peter Freyther <zecke@selfish.org>2013-02-13 20:14:53 +0100
commitcf5b08bcd28e833b5e20bd28cef9afbb2f56fa59 (patch)
tree84a823f974b4a31fd3d45b57453907cc3ed0b1b4 /debian
parentd426d458ca96ba29793e35b1b2a73fbcb3b2c888 (diff)
debian: Create a debug package for the libosmo-abis code
Diffstat (limited to 'debian')
-rw-r--r--debian/control7
-rwxr-xr-xdebian/rules3
2 files changed, 10 insertions, 0 deletions
diff --git a/debian/control b/debian/control
index 42adb80..9a4892e 100644
--- a/debian/control
+++ b/debian/control
@@ -19,3 +19,10 @@ Section: libdevel
Architecture: any
Depends: ${shlibs:Depends}, ${misc:Depends}, libosmocore, libosmo-abis
Description: Development headers for A-bis interface.
+
+Package: libosmo-abis-dbg
+Section: debug
+Architecture: any
+Priority: extra
+Depends: libosmo-abis (= ${binary:Version}), ${misc:Depends}
+Description: Debug symbols for A-bis interface.
diff --git a/debian/rules b/debian/rules
index aa26e09..476c3bf 100755
--- a/debian/rules
+++ b/debian/rules
@@ -9,6 +9,9 @@ export DH_VERBOSE=1
%:
dh --with autoreconf $@ --fail-missing
+override_dh_strip:
+ dh_strip --dbg-package=libosmo-abis-dbg
+
override_dh_autoreconf:
echo $(VERSION) > .tarball-version
dh_autoreconf