aboutsummaryrefslogtreecommitdiffstats
path: root/debian
diff options
context:
space:
mode:
authorHarald Welte <laforge@gnumonks.org>2018-08-06 11:10:29 +0200
committerHarald Welte <laforge@gnumonks.org>2018-08-06 10:06:55 +0000
commita60f5e13b6d21b15d98316855c2834552bfe4606 (patch)
treea5413a7094d1a34c7421a5c57b625e595b79ad1a /debian
parent82eb55e5a1a7520ecec694b900b651d2908d3bd1 (diff)
debian/rules: Don't overwrite .tarball-version
The .tarball-version file should contain the *source version* uniquely identifying the git commit, and not the Debian package name. With https://gerrit.osmocom.org/#/c/osmo-ci/+/10343/ there is a correct .tarball-version file in the .tar.xz of the nightly source packages. Change-Id: I4ce87d474687b61bc2104a02015e954425736123 Related: OS#3449
Diffstat (limited to 'debian')
-rwxr-xr-xdebian/rules6
1 files changed, 1 insertions, 5 deletions
diff --git a/debian/rules b/debian/rules
index 10ba659..f59ca1e 100755
--- a/debian/rules
+++ b/debian/rules
@@ -14,13 +14,9 @@ export DEB_BUILD_MAINT_OPTIONS = hardening=+all
override_dh_strip:
dh_strip --dbg-package=libosmo-abis-dbg
-override_dh_autoreconf:
- echo $(VERSION) > .tarball-version
- dh_autoreconf
-
override_dh_clean:
dh_clean
- rm -f tests/package.m4 tests/testsuite .version .tarball-version
+ rm -f tests/package.m4 tests/testsuite .version
override_dh_auto_test:
dh_auto_test || (find . -name testsuite.log -exec cat {} \; ; false)