aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorPau Espin Pedrol <pespin@sysmocom.de>2018-04-10 18:15:48 +0200
committerPau Espin Pedrol <pespin@sysmocom.de>2018-04-10 18:15:52 +0200
commit43b5b69bb890441c7285541b36ef986063eab8cb (patch)
tree70e2da62e824df9484b79677227d27e935303f1a /configure.ac
parentdb0700a5a33bb3988e3c1d43dbe58e0e1fa7e836 (diff)
configure.ac: Fix condition check for RTP_SIGNAL_PTR_CAST define
While building libosmo-netif on a system with an old ortp (0.22), it was seen that warning related to RTP_SIGNAL_PTR_CAST not being correctly selected were being printed. The compilation didn't fail there as expected because the issue was being handled as a warning instead of an error, so the void* ptr case was always being selected. Change-Id: Ib5e7569e68fdb921c63e0c12e20e73aafbebda46
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index ce4bf39..05fbb12 100644
--- a/configure.ac
+++ b/configure.ac
@@ -110,7 +110,7 @@ AC_COMPILE_IFELSE(
CFLAGS=$_cflags_save
_cflags_save=$CFLAGS
-CFLAGS="$CFLAGS $ORTP_CFLAGS"
+CFLAGS="$CFLAGS $ORTP_CFLAGS -Werror"
AC_COMPILE_IFELSE(
[AC_LANG_PROGRAM(
[[#include <ortp/ortp.h>