aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorHarald Welte <laforge@gnumonks.org>2017-04-04 12:10:54 +0000
committerHarald Welte <laforge@gnumonks.org>2017-04-04 14:34:50 +0200
commitbf7976c0b0076410ad1bd67061dd18d0f33a7f43 (patch)
treed7423c0908b375df769782bb83b102c2f518c3d1 /configure.ac
parent5e87fdfcabc9cabe0025d7350b7ab31cdc4b6fa3 (diff)
Fix HAVE_ORTP_LOG_DOMAIN detection on FreeBSD
We need to use the include path[s] resolved by pkg-config for ortp before trying to compile our test program. Without this patch, compilation will fail e.g. on FreeBSD 11. Change-Id: I0c95e37cc449297389bf31dd9d5dcaa922d75d0c
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 43266be..9b2f189 100644
--- a/configure.ac
+++ b/configure.ac
@@ -59,6 +59,8 @@ then
CPPFLAGS+=" -fsanitize=address -fsanitize=undefined"
fi
+_cflags_save=$CFLAGS
+CFLAGS="$CFLAGS $ORTP_CFLAGS"
AC_COMPILE_IFELSE(
[AC_LANG_PROGRAM(
[[#include <ortp/ortp.h>]],
@@ -68,6 +70,7 @@ AC_COMPILE_IFELSE(
[ortp_set_log_level_mask requires domain parameter])],
[AC_DEFINE([HAVE_ORTP_LOG_DOMAIN], [0],
[ortp_set_log_level_mask has no domain parameter])])
+CFLAGS=$_cflags_save
AC_OUTPUT(
libosmoabis.pc