aboutsummaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules9
1 files changed, 8 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index 267bea9..a1039b0 100755
--- a/debian/rules
+++ b/debian/rules
@@ -32,7 +32,10 @@
# Vendor-related variables such as DEB_VENDOR:
#include /usr/share/dpkg/vendor.mk
# Package-related variables such as DEB_DISTRIBUTION
-#include /usr/share/dpkg/pkg-info.mk
+include /usr/share/dpkg/pkg-info.mk
+
+VERSION := $(shell echo '$(DEB_VERSION)' | sed -e 's/[+-].*//' -e 's/~//g')
+
#
# You may alternatively set them susing a simple script such as:
# DEB_VENDOR ?= $(shell dpkg-vendor --query Vendor)
@@ -44,6 +47,10 @@
%:
dh $@ --with autoreconf
+override_dh_autoreconf:
+ echo $(VERSION) > .tarball-version
+ dh_autoreconf
+
# debmake generated override targets
# Set options for ./configure
#CONFIGURE_FLAGS = <options for ./configure>