aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index b8b5743..aaa2b5a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -28,6 +28,10 @@ AC_COMPILE_IFELSE([AC_LANG_SOURCE([char foo;])],
CFLAGS="$saved_CFLAGS"
AC_SUBST(SYMBOL_VISIBILITY)
+AC_ARG_ENABLE([debug], [AS_HELP_STRING([--enable-debug], [Buld the library with EMIT_ASN_DEBUG enabled])],
+ [build_debug="$enableval"], [build_debug="no"])
+AM_CONDITIONAL(BUILD_DEBUG, test "x$build_debug" = "xyes")
+
AC_OUTPUT(
libasn1c.pc
src/Makefile