aboutsummaryrefslogtreecommitdiffstats
path: root/lib/decoding/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'lib/decoding/CMakeLists.txt')
-rw-r--r--lib/decoding/CMakeLists.txt28
1 files changed, 28 insertions, 0 deletions
diff --git a/lib/decoding/CMakeLists.txt b/lib/decoding/CMakeLists.txt
new file mode 100644
index 0000000..0305a07
--- /dev/null
+++ b/lib/decoding/CMakeLists.txt
@@ -0,0 +1,28 @@
+# Copyright 2011,2012 Free Software Foundation, Inc.
+#
+# This file is part of GNU Radio
+#
+# GNU Radio is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 3, or (at your option)
+# any later version.
+#
+# GNU Radio is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with GNU Radio; see the file COPYING. If not, write to
+# the Free Software Foundation, Inc., 51 Franklin Street,
+# Boston, MA 02110-1301, USA.
+
+
+add_sources(
+ control_channels_decoder_impl.cc
+ tch_f_decoder_impl.cc
+ sch.c
+)
+
+add_subdirectory(osmocom/coding)
+add_subdirectory(openbts)