aboutsummaryrefslogtreecommitdiffstats
path: root/lib/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'lib/CMakeLists.txt')
-rw-r--r--lib/CMakeLists.txt49
1 files changed, 39 insertions, 10 deletions
diff --git a/lib/CMakeLists.txt b/lib/CMakeLists.txt
index 680c41f..9880e58 100644
--- a/lib/CMakeLists.txt
+++ b/lib/CMakeLists.txt
@@ -21,6 +21,29 @@
# Setup library
########################################################################
include(GrPlatform) #define LIB_SUFFIX
+include(GrMiscUtils)
+
+########################################################################
+# Handle the generated constants
+########################################################################
+execute_process(COMMAND ${PYTHON_EXECUTABLE} -c
+ "import time;print time.strftime('%a, %d %b %Y %H:%M:%S', time.gmtime())"
+ OUTPUT_VARIABLE BUILD_DATE OUTPUT_STRIP_TRAILING_WHITESPACE
+)
+message(STATUS "Loading build date ${BUILD_DATE} into constants...")
+message(STATUS "Loading version ${VERSION} into constants...")
+
+#double escape for windows backslash path separators
+string(REPLACE "\\" "\\\\" prefix "${prefix}")
+
+configure_file(
+ ${CMAKE_CURRENT_SOURCE_DIR}/constants.cc.in
+ ${CMAKE_CURRENT_BINARY_DIR}/constants.cc
+ ESCAPE_QUOTES
+@ONLY)
+
+list(APPEND grgsm_sources ${CMAKE_CURRENT_BINARY_DIR}/constants.cc)
+#########################################################################
include_directories(${Boost_INCLUDE_DIR} receiver)
link_directories(${Boost_LIBRARY_DIRS})
@@ -28,21 +51,25 @@ list(APPEND grgsm_sources
receiver/receiver_impl.cc
receiver/receiver_config.cc
receiver/viterbi_detector.cc
- receiver/sch.c
+ decoding/sch.c
receiver/clock_offset_control_impl.cc
receiver/cx_channel_hopper_impl.cc
demapping/universal_ctrl_chans_demapper_impl.cc
demapping/tch_f_chans_demapper_impl.cc
decoding/control_channels_decoder_impl.cc
- decoding/cch.c
- decoding/fire_crc.c
decoding/tch_f_decoder_impl.cc
- decoding/AmrCoder.cpp
- decoding/BitVector.cpp
- decoding/GSM610Tables.cpp
- decoding/GSM660Tables.cpp
- decoding/GSM503Tables.cpp
- decoding/ViterbiR204.cpp
+ decoding/openbts/AmrCoder.cpp
+ decoding/openbts/BitVector.cpp
+ decoding/openbts/GSM610Tables.cpp
+ decoding/openbts/GSM660Tables.cpp
+ decoding/openbts/GSM503Tables.cpp
+ decoding/openbts/ViterbiR204.cpp
+ decoding/osmocom/coding/gsm0503_conv.c
+ decoding/osmocom/coding/gsm0503_coding.c
+ decoding/osmocom/coding/gsm0503_interleaving.c
+ decoding/osmocom/coding/gsm0503_mapping.c
+ decoding/osmocom/coding/gsm0503_parity.c
+ decoding/osmocom/coding/gsm0503_tables.c
flow_control/burst_timeslot_splitter_impl.cc
flow_control/burst_sdcch_subslot_splitter_impl.cc
flow_control/burst_timeslot_filter_impl.cc
@@ -73,13 +100,15 @@ list(APPEND grgsm_sources
add_library(grgsm SHARED ${grgsm_sources})
-target_link_libraries(grgsm ${Boost_LIBRARIES} ${GNURADIO_ALL_LIBRARIES} ${VOLK_LIBRARIES} ${LIBOSMOCORE_LIBRARIES}
+target_link_libraries(grgsm ${Boost_LIBRARIES} ${GNURADIO_ALL_LIBRARIES} ${VOLK_LIBRARIES} ${LIBOSMOCODEC_LIBRARIES} ${LIBOSMOCORE_LIBRARIES}
+# ${LIBOSMOCODING_LIBRARIES}
# libraries required by plotting.h - have troubles to be installed by pybombs
# boost_iostreams
# boost_system
# boost_filesystem
)
set_target_properties(grgsm PROPERTIES DEFINE_SYMBOL "grgsm_EXPORTS")
+GR_LIBRARY_FOO(grgsm)
########################################################################
# Install built library files