aboutsummaryrefslogtreecommitdiffstats
path: root/dists/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'dists/debian/rules')
-rwxr-xr-xdists/debian/rules22
1 files changed, 22 insertions, 0 deletions
diff --git a/dists/debian/rules b/dists/debian/rules
new file mode 100755
index 0000000..d99b9e5
--- /dev/null
+++ b/dists/debian/rules
@@ -0,0 +1,22 @@
+#!/usr/bin/make -f
+
+DEB_HOST_MULTIARCH ?= $(shell dpkg-architecture -qDEB_HOST_MULTIARCH)
+export DEB_HOST_MULTIARCH
+
+%:
+ dh $@ --with python2 --parallel
+
+override_dh_auto_configure:
+ dh_auto_configure -- -DLIB_SUFFIX="/$(DEB_HOST_MULTIARCH)" -DPythonLibs_FIND_VERSION:STRING="2.7" -DPYTHON_EXECUTABLE:STRING="/usr/bin/python"
+
+override_dh_auto_install:
+ dh_auto_install
+
+ # Remove compiled python files
+ rm -f debian/gr-gsm/usr/lib/python2.7/dist-packages/grgsm/*py[co]
+
+ # Use jquery.js file from libjs-jquery instead, see gr-gsm.links
+ rm -f debian/gr-gsm/usr/share/doc/gr-gsm/html/jquery.js
+
+debian/copyright:
+ cme update dpkg-copyright