aboutsummaryrefslogtreecommitdiffstats
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rwxr-xr-xdebian/build-package6
-rw-r--r--debian/changelog2
-rw-r--r--debian/control10
3 files changed, 10 insertions, 8 deletions
diff --git a/debian/build-package b/debian/build-package
index d0d822a..410ef0f 100755
--- a/debian/build-package
+++ b/debian/build-package
@@ -1,8 +1,10 @@
#!/bin/bash
+VERSION=0.33
+
cd ../..
-tar -acf gr-gsm_0.3.orig.tar.gz gr-gsm
+tar -acf gr-gsm_${VERSION}.orig.tar.gz gr-gsm
cd gr-gsm
debuild -S -sa
cd ..
-dput ppa:ptrkrysik/gr-gsm gr-gsm_0.3-0ppa0_source.changes
+#dput ppa:ptrkrysik/gr-gsm gr-gsm_${VERSION}-0ppa0_source.changes
diff --git a/debian/changelog b/debian/changelog
index 2f7a22b..a43cd5c 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,4 +1,4 @@
-gr-gsm (0.3-0ppa0) xenial; urgency=low
+gr-gsm (0.33-0ppa0) xenial; urgency=low
* Initial upload!
diff --git a/debian/control b/debian/control
index d4e5661..d0c5f6c 100644
--- a/debian/control
+++ b/debian/control
@@ -1,13 +1,13 @@
Source: gr-gsm
Section: devel
Priority: optional
-Maintainer: Your Name <your.email@some.where>
-Build-Depends: cmake, build-essential, python-scipy, gnuradio-dev, gr-osmosdr, libosmocore-dev
+Maintainer: Piotr Krysik <ptrkrysik@gmail.com>
+Build-Depends: cmake, python-scipy, gnuradio-dev, gr-osmosdr, libosmocore-dev, swig
-Homepage: http://www.yourhomepage.org
+Homepage: http://github.com/ptrkrysik/gr-gsm.git
Package: gr-gsm
Architecture: any
-Depends: ${shlibs:Depends}, ${misc:Depends}, gnuradio, gr-osmosdr, python-scipy
-Description: First test-package
+Depends: gnuradio, gr-osmosdr, python-scipy, ${shlibs:Depends}, ${misc:Depends}
+Description: Gnuradio blocks and tools for receiving GSM transmissions
Long description of greet-the-world.
It can span multiple lines!