aboutsummaryrefslogtreecommitdiffstats
path: root/lib/CMakeLists.txt
diff options
context:
space:
mode:
authorPiotr Krysik <ptrkrysik@gmail.com>2017-01-03 08:01:23 +0100
committerPiotr Krysik <ptrkrysik@gmail.com>2017-01-03 08:01:23 +0100
commit70c25a112a3a8637dccafb278ca27a96ba950117 (patch)
tree087a08f8fcd582fa4950325ebf8823ea33652f65 /lib/CMakeLists.txt
parent25ae3e2066e589f7faf2ddf9b1811697583233ac (diff)
Changes in decoding:
-copied decoding routines from libosmocore to gr-gsm, -made cmake files entries for new source files and added linking with libosmocodec, -moved sch.c file to decoding folder.
Diffstat (limited to 'lib/CMakeLists.txt')
-rw-r--r--lib/CMakeLists.txt11
1 files changed, 9 insertions, 2 deletions
diff --git a/lib/CMakeLists.txt b/lib/CMakeLists.txt
index 4c18c18..4b4a993 100644
--- a/lib/CMakeLists.txt
+++ b/lib/CMakeLists.txt
@@ -28,7 +28,7 @@ list(APPEND grgsm_sources
receiver/receiver_impl.cc
receiver/receiver_config.cc
receiver/viterbi_detector.cc
- receiver/sch.c
+ decoding/sch.c
receiver/clock_offset_control_impl.cc
receiver/cx_channel_hopper_impl.cc
demapping/universal_ctrl_chans_demapper_impl.cc
@@ -41,6 +41,12 @@ list(APPEND grgsm_sources
decoding/GSM660Tables.cpp
decoding/GSM503Tables.cpp
decoding/ViterbiR204.cpp
+ decoding/osmocom/coding/gsm0503_conv.c
+ decoding/osmocom/coding/gsm0503_coding.c
+ decoding/osmocom/coding/gsm0503_interleaving.c
+ decoding/osmocom/coding/gsm0503_mapping.c
+ decoding/osmocom/coding/gsm0503_parity.c
+ decoding/osmocom/coding/gsm0503_tables.c
flow_control/burst_timeslot_splitter_impl.cc
flow_control/burst_sdcch_subslot_splitter_impl.cc
flow_control/burst_timeslot_filter_impl.cc
@@ -69,7 +75,8 @@ list(APPEND grgsm_sources
add_library(grgsm SHARED ${grgsm_sources})
-target_link_libraries(grgsm ${Boost_LIBRARIES} ${GNURADIO_ALL_LIBRARIES} ${VOLK_LIBRARIES} ${LIBOSMOCORE_LIBRARIES} ${LIBOSMOCODING_LIBRARIES}
+target_link_libraries(grgsm ${Boost_LIBRARIES} ${GNURADIO_ALL_LIBRARIES} ${VOLK_LIBRARIES} ${LIBOSMOCODEC_LIBRARIES} ${LIBOSMOCORE_LIBRARIES}
+# ${LIBOSMOCODING_LIBRARIES}
# libraries required by plotting.h - have troubles to be installed by pybombs
# boost_iostreams
# boost_system