aboutsummaryrefslogtreecommitdiffstats
path: root/include/grgsm/decoding/CMakeLists.txt
diff options
context:
space:
mode:
authorVasil Velichkov <vvvelichkov@gmail.com>2018-05-06 02:13:36 +0300
committerPiotr Krysik <ptrkrysik@gmail.com>2018-12-29 00:52:05 +0100
commit7f259fdb68025d6e7b3cfc36c3958d9c6e5f60b8 (patch)
tree020b7e2f240dbeb31182cade86e5f62ac1863c73 /include/grgsm/decoding/CMakeLists.txt
parent0ccec373b3d68825d02b4494b3e2c90bda86a471 (diff)
Add TCH/H decoder block with AMR multirate support
Add new TCHH channel mode Add two new optional arguments -m CHAN_MODE, --mode=CHAN_MODE Channel mode. Valid options are 'BCCH' (Non-combined C0), 'BCCH_SDCCH4'(Combined C0), 'SDCCH8' (Stand-alone control channel) 'TCHF' (Traffic Channel, Full rate), 'TCHH' (Traffic Channel, Half rate) --sub-channel=TCH_H_CHANNEL TCH/H sub-channel. [default=0] --multi-rate=MULTI_RATE The MultiRrate configuration element from the Assigment Command message. Example: 28111a40. See 3GPP TS 44.018 - 10.5.2.21aa MultiRate configuration Example: grgsm_decode -m TCHH --sub-channel 0 --multi-rate 2811 -o voice.amr ...
Diffstat (limited to 'include/grgsm/decoding/CMakeLists.txt')
-rw-r--r--include/grgsm/decoding/CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/include/grgsm/decoding/CMakeLists.txt b/include/grgsm/decoding/CMakeLists.txt
index 64bbb16..1014955 100644
--- a/include/grgsm/decoding/CMakeLists.txt
+++ b/include/grgsm/decoding/CMakeLists.txt
@@ -22,5 +22,7 @@
########################################################################
install(FILES
control_channels_decoder.h
- tch_f_decoder.h DESTINATION include/grgsm/decoding
+ tch_f_decoder.h
+ tch_h_decoder.h
+ DESTINATION include/grgsm/decoding
)