aboutsummaryrefslogtreecommitdiffstats
path: root/debian
diff options
context:
space:
mode:
authorPiotr Krysik <ptrkrysik@gmail.com>2016-06-21 07:13:48 +0200
committerPiotr Krysik <ptrkrysik@gmail.com>2016-06-21 07:13:48 +0200
commit5de014a1c7358f9e6cde8dc4c1501fecc36adf96 (patch)
treeaf6a223fcb81393f15c86a3650553d7a5beae3f6 /debian
parent5c7b3748b17cbd58945f46db2f937fdaf19e8729 (diff)
Changes to the Debian packaging files
Diffstat (limited to 'debian')
-rwxr-xr-xdebian/build-package3
-rw-r--r--debian/changelog2
-rw-r--r--debian/compat1
-rw-r--r--debian/control23
-rwxr-xr-xdebian/rules32
-rw-r--r--debian/source/format1
6 files changed, 32 insertions, 30 deletions
diff --git a/debian/build-package b/debian/build-package
index 410ef0f..3138942 100755
--- a/debian/build-package
+++ b/debian/build-package
@@ -1,10 +1,11 @@
#!/bin/bash
-VERSION=0.33
+VERSION=0.36
cd ../..
tar -acf gr-gsm_${VERSION}.orig.tar.gz gr-gsm
cd gr-gsm
debuild -S -sa
+#pdebuild
cd ..
#dput ppa:ptrkrysik/gr-gsm gr-gsm_${VERSION}-0ppa0_source.changes
diff --git a/debian/changelog b/debian/changelog
index a43cd5c..0c21e21 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,4 +1,4 @@
-gr-gsm (0.33-0ppa0) xenial; urgency=low
+gr-gsm (0.36-0ppa0) xenial; urgency=low
* Initial upload!
diff --git a/debian/compat b/debian/compat
new file mode 100644
index 0000000..f11c82a
--- /dev/null
+++ b/debian/compat
@@ -0,0 +1 @@
+9 \ No newline at end of file
diff --git a/debian/control b/debian/control
index d0c5f6c..38c312e 100644
--- a/debian/control
+++ b/debian/control
@@ -1,13 +1,24 @@
Source: gr-gsm
-Section: devel
+Section: libdevel
Priority: optional
Maintainer: Piotr Krysik <ptrkrysik@gmail.com>
-Build-Depends: cmake, python-scipy, gnuradio-dev, gr-osmosdr, libosmocore-dev, swig
+Build-Depends: cmake,
+ debhelper (>= 9.0.0~),
+ pkg-config,
+ python-scipy,
+ gnuradio-dev,
+ libosmocore-dev,
+ python-dev,
+ swig
+X-Python-Version: >= 2.7, << 2.8
+Standards-Version: 3.9.7
+Homepage: http://github.com/ptrkrysik/gr-gsm/
+Vcs-Git: git://github.com/ptrkrysik/gr-gsm.git
+Vcs-Browser: https://github.com/ptrkrysik/gr-gsm/
-Homepage: http://github.com/ptrkrysik/gr-gsm.git
Package: gr-gsm
Architecture: any
-Depends: gnuradio, gr-osmosdr, python-scipy, ${shlibs:Depends}, ${misc:Depends}
+Pre-Depends: ${misc:Pre-Depends}
+Depends: ${misc:Depends}, ${python:Depends}, ${shlibs:Depends}
Description: Gnuradio blocks and tools for receiving GSM transmissions
- Long description of greet-the-world.
- It can span multiple lines!
+
diff --git a/debian/rules b/debian/rules
index 6b44c5b..cb59406 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,27 +1,15 @@
#!/usr/bin/make -f
+DEB_HOST_MULTIARCH ?= $(shell dpkg-architecture -qDEB_HOST_MULTIARCH)
+export DEB_HOST_MULTIARCH
-BUILDDIR = build
+%:
+ dh $@ --with python2 --parallel
-# secondly called by launchpad
-build:
- mkdir $(BUILDDIR);
- cd $(BUILDDIR); cmake -DCMAKE_INSTALL_PREFIX=../debian/tmp/usr ..
- make -C $(BUILDDIR)
+override_dh_auto_configure:
+ dh_auto_configure -- -DLIB_SUFFIX="/$(DEB_HOST_MULTIARCH)" -DPythonLibs_FIND_VERSION:STRING="2.7" -DPYTHON_EXECUTABLE:STRING="/usr/bin/python"
-# thirdly called by launchpad
-binary: binary-indep binary-arch
+override_dh_auto_install:
+ dh_auto_install
+ rm -f debian/gr-gsm/usr/lib/python2.7/dist-packages/grgsm/*pyc
+ rm -f debian/gr-gsm/usr/lib/python2.7/dist-packages/grgsm/*pyo
-binary-indep:
- # nothing to be done
-
-binary-arch:
- cd $(BUILDDIR); cmake -P cmake_install.cmake
- mkdir debian/tmp/DEBIAN
- dpkg-gencontrol -pgr-gsm
- dpkg --build debian/tmp ..
-
-# firstly called by launchpad
-clean:
- rm -rf $(BUILDDIR)
-
-.PHONY: binary binary-arch binary-indep clean
diff --git a/debian/source/format b/debian/source/format
new file mode 100644
index 0000000..46ebe02
--- /dev/null
+++ b/debian/source/format
@@ -0,0 +1 @@
+3.0 (quilt) \ No newline at end of file