aboutsummaryrefslogtreecommitdiffstats
path: root/debian
diff options
context:
space:
mode:
authorPiotr Krysik <ptrkrysik@gmail.com>2016-04-25 10:28:44 +0200
committerPiotr Krysik <ptrkrysik@gmail.com>2016-04-25 10:28:44 +0200
commit062e32c901268a90bcfdb6f70776a3626de3b32b (patch)
tree55e66529a123e31fa30b6897a4d8211b6e24dc83 /debian
parent13d9e7a3341f752b239ed1eec3c3aae85ad39afe (diff)
Added files from the example:
http://simmesimme.github.io/lessons/2011/11/02/ppa-launchpad-cmake/ after slight change in order to make launchpad compile gr-gsm.
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog5
-rw-r--r--debian/control13
-rw-r--r--debian/copyright18
-rwxr-xr-xdebian/rules27
4 files changed, 63 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
new file mode 100644
index 0000000..2f7a22b
--- /dev/null
+++ b/debian/changelog
@@ -0,0 +1,5 @@
+gr-gsm (0.3-0ppa0) xenial; urgency=low
+
+ * Initial upload!
+
+ -- Piotr Krysik <ptrkrysik@gmail.com> Sun, 24 Apr 2016 16:00:00 +0100
diff --git a/debian/control b/debian/control
new file mode 100644
index 0000000..d4e5661
--- /dev/null
+++ b/debian/control
@@ -0,0 +1,13 @@
+Source: gr-gsm
+Section: devel
+Priority: optional
+Maintainer: Your Name <your.email@some.where>
+Build-Depends: cmake, build-essential, python-scipy, gnuradio-dev, gr-osmosdr, libosmocore-dev
+
+Homepage: http://www.yourhomepage.org
+Package: gr-gsm
+Architecture: any
+Depends: ${shlibs:Depends}, ${misc:Depends}, gnuradio, gr-osmosdr, python-scipy
+Description: First test-package
+ Long description of greet-the-world.
+ It can span multiple lines!
diff --git a/debian/copyright b/debian/copyright
new file mode 100644
index 0000000..51af985
--- /dev/null
+++ b/debian/copyright
@@ -0,0 +1,18 @@
+####################################################################
+# gr-gsm #
+####################################################################
+
+Copyright (C) 2011 Your Name
+
+This program is free software: you can redistribute it and/or modify
+it under the terms of the GNU General Public License as published by
+the Free Software Foundation, either version 3 of the License, or
+(at your option) any later version.
+
+This program is distributed in the hope that it will be useful, but
+WITHOUT ANY WARRANTY; without even the implied warranty of
+MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+General Public License for more details.
+
+You should have received a copy of the GNU General Public License
+along with this program. If not, see <http://www.gnu.org/licenses/>.
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..6b44c5b
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,27 @@
+#!/usr/bin/make -f
+
+BUILDDIR = build
+
+# secondly called by launchpad
+build:
+ mkdir $(BUILDDIR);
+ cd $(BUILDDIR); cmake -DCMAKE_INSTALL_PREFIX=../debian/tmp/usr ..
+ make -C $(BUILDDIR)
+
+# thirdly called by launchpad
+binary: binary-indep binary-arch
+
+binary-indep:
+ # nothing to be done
+
+binary-arch:
+ cd $(BUILDDIR); cmake -P cmake_install.cmake
+ mkdir debian/tmp/DEBIAN
+ dpkg-gencontrol -pgr-gsm
+ dpkg --build debian/tmp ..
+
+# firstly called by launchpad
+clean:
+ rm -rf $(BUILDDIR)
+
+.PHONY: binary binary-arch binary-indep clean