aboutsummaryrefslogtreecommitdiffstats
path: root/apps/CMakeLists.txt
diff options
context:
space:
mode:
authorPiotr Krysik <ptrkrysik@users.noreply.github.com>2017-08-28 17:56:21 +0200
committerGitHub <noreply@github.com>2017-08-28 17:56:21 +0200
commit440dcea64e333994d818a03231febd7765dd959d (patch)
tree54798532acd915eaf5e04183e0799f0c7b6a4354 /apps/CMakeLists.txt
parentccab28dffe75a0d4528b48ce6461fe8524872e1b (diff)
parent56825a7ae87dfc5e5d729cea8cc975c282f1b719 (diff)
Merge branch 'packaging' into desktop-menu-entry
Diffstat (limited to 'apps/CMakeLists.txt')
-rw-r--r--apps/CMakeLists.txt17
1 files changed, 6 insertions, 11 deletions
diff --git a/apps/CMakeLists.txt b/apps/CMakeLists.txt
index 3f698f7..09e7257 100644
--- a/apps/CMakeLists.txt
+++ b/apps/CMakeLists.txt
@@ -18,7 +18,6 @@
# Boston, MA 02110-1301, USA.
include(GrPython)
-include(CreateSymlink)
add_subdirectory(helpers)
GR_PYTHON_INSTALL(
@@ -29,18 +28,14 @@ GR_PYTHON_INSTALL(
DESTINATION bin
)
-SET(XDG_DESKTOP_DIR "/usr/share/applications/")
-INSTALL (FILES grgsm_livemon.desktop DESTINATION ${XDG_DESKTOP_DIR})
-
-#CREATE_SYMLINK(grgsm_livemon airprobe_rtlsdr.py)
-#CREATE_SYMLINK(grgsm_decode airprobe_decode.py)
-#CREATE_SYMLINK(grgsm_scanner airprobe_rtlsdr_scanner.py)
-
-add_custom_target(apps_symlinks ALL DEPENDS ${symlinks})
-
install(
PROGRAMS
- ${symlinks}
DESTINATION bin
)
+set(XDG_DESKTOP_DIR "/usr/share/applications/")
+install(
+ FILES
+ grgsm_livemon.desktop
+ DESTINATION ${XDG_DESKTOP_DIR}
+)