aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorptrkrysik <ptrkrysik@gmail.com>2014-12-13 10:11:00 +0100
committerptrkrysik <ptrkrysik@gmail.com>2014-12-13 10:11:00 +0100
commit3be74a732b3fc4de0f99249e8bca975fee760210 (patch)
tree81731b4d5022ce40f8b0983c310c42f7d1a6838f /CMakeLists.txt
parent0cd9ef0a801eeab7f501d012006f379b86c887a1 (diff)
Changed grgsm install directories and prefixes from "gsm" to "grgsm". The old prefix caused conflicts with libraries already available.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt14
1 files changed, 7 insertions, 7 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 9572792..2d1efc3 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -70,11 +70,11 @@ endif()
include(GrPlatform) #define LIB_SUFFIX
set(GR_RUNTIME_DIR bin)
set(GR_LIBRARY_DIR lib${LIB_SUFFIX})
-set(GR_INCLUDE_DIR include/gsm)
-set(GR_INCLUDE_DIR include/gsm/misc_utils)
-set(GR_INCLUDE_DIR include/gsm/receiver)
-set(GR_INCLUDE_DIR include/gsm/demapping)
-set(GR_INCLUDE_DIR include/gsm/decoding)
+set(GR_INCLUDE_DIR include/grgsm)
+set(GR_INCLUDE_DIR include/ggrsm/misc_utils)
+set(GR_INCLUDE_DIR include/grgsm/receiver)
+set(GR_INCLUDE_DIR include/grgsm/demapping)
+set(GR_INCLUDE_DIR include/grgsm/decoding)
set(GR_DATA_DIR share)
set(GR_PKG_DATA_DIR ${GR_DATA_DIR}/${CMAKE_PROJECT_NAME})
set(GR_DOC_DIR ${GR_DATA_DIR}/doc)
@@ -151,7 +151,7 @@ add_custom_target(uninstall
########################################################################
# Add subdirectories
########################################################################
-add_subdirectory(include/gsm)
+add_subdirectory(include/grgsm)
add_subdirectory(include/plotting)
add_subdirectory(lib)
add_subdirectory(swig)
@@ -164,5 +164,5 @@ add_subdirectory(docs)
# Install cmake search helper for this library
########################################################################
install(FILES cmake/Modules/gsmConfig.cmake
- DESTINATION lib/cmake/gsm
+ DESTINATION lib/cmake/grgsm
)